Results 1 to 3 of 3

Thread: radiator leaks only when the car's cold.

  1. #1
    Junior Member
    Join Date
    May 2007
    Location
    Cedar Rapids, IA
    Posts
    22

    radiator leaks only when the car's cold.

    My radiator leaks about a dozen drops a night after I run it. It doesn't leak any when it's hot. Any ideas where or how it can be fixed? It seems to leak about half way down on the side opposite the top hose so it's not the hose.

  2. #2
    Senior Member sLoWnStEaDy's Avatar
    Join Date
    Sep 2004
    Location
    S.W. Cedar Rapids
    Posts
    4,251
    Doesn't make sense to me it would only leak when it's "cold", you probably just don't notice it while running if it's only about a drop an hour like you say. I mean, I doubt you have it running and sitting in one spot for long enough to notice such a small amount. It should be more likely to leak when hot and pressurized. If it's on the radiator itself, should be a fairly easy leak to find. Pull the fan shroud, grab a light and take a look. Should be a trail to follow back to the source. If it is not a hose, it's got to be a crack/hole, obviously. depending on where it is, there are a few ways to fix it, gotta find it first though.

    I've had a row leaking on a POS daily beater and simply pinched that row closed, folded it over a few times and soldered it. kinda "ghetto" but it fixed the leak and never gave me an issue with over 300K miles on it (Jeep, 4.0 I-6). Also had an end tank crack on an aluminum radiator, cleaned it up, and used some JB weld temporarily to get me by until I got time to pull it and have the crack welded. It will also depend on whether your end tanks are plastic or aluminum... Again, just depends on where the crack is and how you feel like fixing it.

  3. #3
    Owner AutoMods's Avatar
    Join Date
    Jan 2005
    Location
    North Liberty
    Posts
    5,084
    I have a similar issue. I have a small drip from a radiator hose to lower radiator connection only when the car cools down. Only drips about a teaspoon worth, doesn't do it every time. The hose connection isn't perfect, kind of a weird angle. but I figure its due to a pressure change while the car is cooling down.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •