Results 1 to 5 of 5

Thread: tested some 4g63 talon injectors for a local guy

  1. #1
    Owner AutoMods's Avatar
    Join Date
    Jan 2005
    Location
    North Liberty
    Posts
    5,084

    tested some 4g63 talon injectors for a local guy

    tested some fic injectors for a local guy on the flow bench. they were FIC 750cc . customer was having some rough idle he couldn't get figured out. turns out, number 4 injector was not firing at all ...zero flow. the car had been sitting for couple years, it was even sometimes fired up briefly and idled just to try to prevent something like this. but anyway, a coil or something inside probably corroded and locked up

    stevo told me he had seen this happen before and had shocked the injector with some voltage and got it to reopen in the past. could be worth trying but you'd want to flow test it even then to make sure it flows correct still.

    moral of the story, try not to let your injectors sit around. and watch out when you buy used, make sure the previous owner didn't have them laying around for too long.

    very possible to have a the injector still fire but be partially on its way out being partially corroded or weakened coil. this will just create uneven flow like dustin's duster's injectors i tested a while back



    If anyone wants to store their injectors for the winter, I can test, clean and oil them up for storage and seal them. pm me
    Last edited by AutoMods; 11-17-2012 at 08:54 PM.

  2. #2
    Moderator Batwood's Avatar
    Join Date
    Jan 2010
    Location
    Cedar Rapids
    Posts
    1,072
    Mine are heading your way next week. :/
    RIP - Twincharged Regal.
    04 Cobra - 11.4@123 ... 507whp/501wtq (2012)
    10.7@133 ... 641whp/610wtq (2013)
    9.999@141.00... Auto/SRA(2014)

  3. #3
    IAF Team Member Clinical's Avatar
    Join Date
    Nov 2008
    Posts
    2,262
    Quote Originally Posted by ImportEvolution View Post
    tested some fic injectors for a local guy on the flow bench. they were FIC 750cc . customer was having some rough idle he couldn't get figured out. turns out, number 4 injector was not firing at all ...zero flow. the car had been sitting for couple years, it was even sometimes fired up briefly and idled just to try to prevent something like this. but anyway, a coil or something inside probably corroded and locked up

    stevo told me he had seen this happen before and had shocked the injector with some voltage and got it to reopen in the past. could be worth trying but you'd want to flow test it even then to make sure it flows correct still.

    moral of the story, try not to let your injectors sit around. and watch out when you buy used, make sure the previous owner didn't have them laying around for too long.

    very possible to have a the injector still fire but be partially on its way out being partially corroded or weakened coil. this will just create uneven flow like dustin's duster's injectors i tested a while back



    If anyone wants to store their injectors for the winter, I can test, clean and oil them up for storage and seal them. pm me
    Sounds a lot like what my GS-T was doing, figured they just needed a good cleaning. Popped a junkyard stocker in it and it fixed it perfectly cause I was too lazy to get mine cleaned

    1994 Eagle Talon TSi AWD
    2008 Dodge Caliber SRT-4
    1994 Eagle Talon ES
    2006 Suzuki DRZ400SM
    2001 Kawasaki Ninja ZX-9R

  4. #4
    Senior Member sLoWnStEaDy's Avatar
    Join Date
    Sep 2004
    Location
    S.W. Cedar Rapids
    Posts
    4,251
    The cutlass I sold LT1Dan years back had an injector seize up when he was checking it out. Threw straight voltage from the battery at it for a split second and she opened right up. To the best of my knowledge, it ran like a champ the entire time he had it. I'm probably doing it wrong but when I store injectors, I run staybill digging oil through them and then vacuum seal em. No issues thus far and I've been doing it years. My fiero injectors sat like that for about 6 years and I tossed them in my new crate motor and they seem to be perfect. I haven't flowed em but they were stock 24lb'ers and a dime a dozen anyways but...

  5. #5
    Senior Member LT1Dan's Avatar
    Join Date
    Sep 2009
    Location
    Marion
    Posts
    1,074
    Ha I almost forgot about that thing. Yeah it ran fine the whole time I had it. Replaced a brake line that rusted while I had it and sold it for what I paid.
    2012 IAF Rob Palmer Shootout Auto Runner Up (Chekal cheated)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •